Icon transparency

0 Members and 1 Guest are viewing this topic.

**
Rep: +0/-0Level 38
RMRK Junior
Hello folks, I'm new here but I'm really enjoying building things here.

However I have a problem.  I found some addition icons I'd like to add and learned how to add them to IconSet.png as well as moving it to the local file instead of using the base file.

However, every time I've modified the file, I lose the transparency the icons had. 

Further reading said that this was an issue for Win7 but wondering if there was a work around available?

*
Rep:
Level 85
I solve practical problems.
For taking arms in the name of your breakfast.
Were the modifications done in stock Win7Paint, because you could always manually ensure that the entire Iconset.png image has transparent backgrounds by deleting the background in GIMP or Photoshop.

**
Rep: +0/-0Level 38
RMRK Junior
Well, that sorta worked...

I used GIMP to try and fix this, but it seems that there's no separate layers or don't know how this works.

I have transparency now by selecting the black, but everything's all washed out and faded.

Here's what my results are:

*
Rep:
Level 85
I solve practical problems.
For taking arms in the name of your breakfast.
Oh dear, seems that the color of the background is the same as the borders of the item sprites, unless you have to low of a tolerance on your selection tool, is that the case?

**
Rep: +0/-0Level 38
RMRK Junior
?

I have no idea what that is...

But I did try seeing if any other color on the scale would work and no, it had to be 000000000 before I got transparency.

*
Rep:
Level 85
I solve practical problems.
For taking arms in the name of your breakfast.
I think the background of your image is the exact same as the border of the icons, the only fix is to manualy erase the background with the eraser tool or to just start over, making sure that the background is always a different color than the icon borders, I like to use a bright magenta as my background because its very rare that sprites use it.