Advanced Text System 3.0c

0 Members and 1 Guest are viewing this topic.

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
As for 4, the text speed skip on user input... The default message speed system just speeds up the message if I press the key once and hold. It only shows the message instantly if I press the key twice and it stops before the \! command as well so user input must go in again. But well, with the ATS, it just skips all that with a single press. Yes, even if I put "SCROLLING = false" it still puts the whole thing instantly and does not stop after each sentence, not stopping for the \! command.

The default message system does skip all immediately - I'm sure about that. I just tested in a blank project - you might have had a different message system if it didn't - but I am pretty sure that default skips the whole message too. It shouldn't skip \! codes though, so I will look into that.

For (1) - if you have the extraction bug fix, then you need to do the same modification I suggested to that since it overwrites that method - It seems to be working for me.

For the skipping past \!, try adding this code into its own slot in the editor, somewhere below the ATS. See if it will still skip.

Code: [Select]
class Window_Message
  alias modrnalg_atsbugfix_pause_skip_0bh2 draw_message_character
  def draw_message_character (c)
    if c == "\x04"
      @show_fast = false
      @line_show_fast = false
    end
    modrnalg_atsbugfix_pause_skip_0bh2 (c)
  end
end

I really should work on Version 3.0 one of these days.

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
I am considering writing a major update for this script very soon. If anyone has any features to suggest that I add (or unresolved bugs), speak now or forever hold your peace.
« Last Edit: August 14, 2009, 03:55:14 PM by modern algebra »

**
Rep:
Level 83
Wow, yes thank you, those problems have now been fixed. Awesome!

As for user input to skip all text, I guess I meant when \! was used within it. Without those then yes the whole message appeared instantly. Sorry if I didn't say it well enough.

And yes that'd be awesome to make a 3.0 it's a truly awesome script and many others agree with that I am sure. I think its the best message script out there!

Though... I don't know how much better it can be improved, with these fixes it seems more perfect than before. There may still be some deals with faces delaying to erase but that is minor.
« Last Edit: August 15, 2009, 04:49:39 AM by Raukue »

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox
Is it compatable with all fonts?

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
It's compatible with any fonts that work in RMVX. I've never encountered a font that it didn't work with.

****
Rep:
Level 84
3...2...1...
With the font, how do you change it everywhere.  I have changed it in the script, but it only changes namebox, and choice box.  How do you change it for the title, and menu, and everything?

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox
How do I do it,



I downloaded a font

Installed the font

Put it in the font folder

It had underscores in the name, I copied the name and put it in the script
where there's 3 font names.

Play the game and it don't show the font, just plane text.



By the way, nice script.  8)


*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
Show me how you put it in the script. It should be before all the other fonts.

In any case, the script uses the RMVX Font class - it doesn't do anything to modify it.

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox
False alarm :police:

The font was messed up, I got it to work perfectly. :mad:

But :mad:

Now I'm having trouble with the message box, It won't adjust in the opacity. And can I change it's size?

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
Are the below codes not working for you?

Code: [Select]

$game_message.message_width = positive integer
$game_message.message_height = positive integer
$game_message.message_opacity = integer (between 0 and 255)

****
Rep:
Level 84
3...2...1...
I'm probably doing this way wrong, but I change the font on the script "ATS Version 2.0" at lines 226, 298, and 341.  I can't find anywhere to change it altogether.  I'm no good at scripting...can ya' tell?

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox
Sorry for the misunderstanding, I meant the namebox.

Is there a way to change it all together.

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
I'm probably doing this way wrong, but I change the font on the script "ATS Version 2.0" at lines 226, 298, and 341.  I can't find anywhere to change it altogether.  I'm no good at scripting...can ya' tell?

Hey, no you're doing it right. I just have fonts separated - One is the font of the message box, one is the name box, and the other is the choice box. They are all separate because I figured some people might not want to have the same fonts for everything.

Sorry for the misunderstanding, I meant the namebox.

Is there a way to change it all together.

What do you mean altogether?

The size of the name box is unadjustable - it is based on the width of whatever text you put in there. So it will be shorter for Ben and longer for Benjamin.

As for opacity, are these codes not working?

Code: [Select]
$game_message.namebox_opacity =
$game_ats.namebox_opacity =

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox
I mean like in stead of going to each event and adding a call script.

When I try to change the opacity in the script, there's no effect. :aryan: <= What is this thing?

****
Rep:
Level 84
3...2...1...
Cam you cange the font for the title and menu.  And example would be in Leventhan's game Sunken Oculus.  He's got the same text for the title, menu, and all the in-game text.

****
kikiki
Rep:
Level 84
Hi
awww i wish there was one for RMXP

Hi

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
I mean like in stead of going to each event and adding a call script.

When I try to change the opacity in the script, there's no effect. :aryan: <= What is this thing?

You mean, when you change this:

Code: [Select]
    NAMEBOX_OPACITY = 255 # The opacity of the name box

it makes no difference? I don't know what to tell you - it works for me. If that isn't working, then you might have it overwritten somewhere.

Also, you can change the global setting of any command by changing it in $game_ats. You have to follow it by clearing $game_message though, if you want it to be in effect for the very next message.

So:

Code: [Select]
$game_ats.namebox_opacity = 255
$game_message.clear

Cam you cange the font for the title and menu.  And example would be in Leventhan's game Sunken Oculus.  He's got the same text for the title, menu, and all the in-game text.

Not with this script. This is a message script, so I didn't change all that stuff. But try this script: http://rmrk.net/index.php?topic=26246.0

****
Rep:
Level 84
3...2...1...
Alright, that other script works great.  Thanks much.

***
Sk8r Boi
Rep:
Level 83
Skater's Handy Fox

**
Rep:
Level 83
Sorry about this double post but I ran across another thing...


\nb[\n[2]]\%Have a seat here. \!I'll be back with something.


1.) That line there, something skips too soon when there should be room. I tried getting rid of the \! and \% commands and still. Though... its odd, if i put them all together, the same message, they all appear on one line each, except for the last one where the word "something" skips to the next line.

So yeah I suppose that's another problem there that I dunno why that happens.


2.) Another thing about it... I am using Yanfly's Battle Redux and when I try to escape, the message appears on the bottom over the Fight and status, rather than on top where the command should go. I take away the ATS script and it appears correctly on top. Of course I don't want to go back ATS'less.

3.) Just came across this one... I am using Wora's Neo Save System 3, when I tried loading my game I got a stack level too deep error on your ATS script. I dunno if it has anything to do with Wora's script there but I bring it up just in case. Though I loaded my game again and it went through fine. Then how I tried a new game and got another stack level too deep

line 1874:
   start_choice if $game_message.choicebox && !$game_message.choice_texts.empty?

Though I tried a new game again and it went through alright. I dunno if this has to do with your ATS script at all or if its because of other scripts that cause it. It's just... odd. So yeah I don't know if this is part of your script or just on my fault of having many scripts, though even though I have many I have worked out the kinks with them pretty much.
« Last Edit: August 17, 2009, 07:49:47 AM by Raukue »

**
Rep:
Level 83
Hi !

First of all , THANKS for this script . this is awesome . i will raise a statue of you in my next game :)

But .... i have a small issue , look at this screen :


Here is the original text :
Voulez-vous jouer en mode developpeur ?\lb
Vous aurez accés au commentaire du créateur du jeu et vous
pourrez meme ... tricher .\lb
(yes , it is in french) .

As you can see , a word "créateur" is truncated ...

This is not a major issue because i can put a \lb before , but ...
You can use my scripts freely . but not for commercial use .
:ccbync:
Don't encrypt your game !!!
Want to give me credit ? Easy ,add me in your game :

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
1) That doesn't seem to be a problem to me... Are you saying that if you take away everything and make the message: Have a seat here. I'll be back with something.
then it takes up two lines when it looks like it shouldn't, then there's not a lot I can do. Either it just looks like it can but really can't (the last 16 pixels of any window are unusable) or it has to do with the text_size method of Bitmap

I could try a text_size fix if I had your font. The easiest thing would simply be to change the message slightly so that it isn't noticeable. Something like:

\nb[\n[2]]\%Have a seat here. \!I'll be right back with something.

2) I'd need to see the script in order to fix that. As a preliminary, try putting Yanfly's script underneath the ATS. If that doesn't work, link me to Yanfly's script

3) A Stack Level Too Deep error is likely caused by an incompatibility with other scripts. They're tricky though, because they don't say which method is being called recursively. It could easily be an incompatibility between the ATS or any script, or between any two scripts not the ATS, or between multiple scripts. I'd need for you to find out what scripts are the culprits and tell me.

It appears to be happening in Scene_Title, since it sometimes occurs in New Game and sometimes when Loading. So, likely one of the scripts has something to do with Scene_Title. If you can reproduce the error in a different project and send it to me than I can look through it. Otherwise you will have to find out by one-by-one script deletion, though it doesn't seem to be very reliable if sometimes you can start a new game and sometimes you can't. It might have something to do with the map conditions of the starting map. IDK

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
Hi !

First of all , THANKS for this script . this is awesome . i will raise a statue of you in my next game :)

But .... i have a small issue , look at this screen :


Here is the original text :
Voulez-vous jouer en mode developpeur ?\lb
Vous aurez accés au commentaire du créateur du jeu et vous
pourrez meme ... tricher .\lb
(yes , it is in french) .

As you can see , a word "créateur" is truncated ...

This is not a major issue because i can put a \lb before , but ...


Hmm, yeah it shouldn't happen. The spaces at the starts of those lines shouldn't happen either. For now, just put the \lb. If it becomes common I will have to look into it more closely. I suspect the problem has to do with the text_size method of bitmap and incorrectly calculating for french characters.
« Last Edit: August 31, 2009, 01:53:15 PM by modern algebra »

**
Rep:
Level 83
1.) Well I should say a face is there. And if I put that same message, one after the other, it all appears in one line, it fits. I put 3 in a row, the first 2 appear all in one line, but the last one, the word something skips to the next line when the other 2 lines show that it can all fit on one line.

Case 1:


Case 2:


2.) The battle script is under yours. A link to the script.
http://pockethouse.wordpress.com/vx/scene-battle-redux/



The text appears slowly like when out of battle and talking to someone, rather than just instant like the rest of the actions.

3.) As for that stack error... so far it's only happened once but... maybe I will look into it. Once I post the demo of what I am building, which is a demo of scripts together to perhaps use as a base for a game, then I will link you to it. But I have another scripter looking at it so that might not be a problem. Don't know how I can reproduce the error when it hasn't shown up again so... dunno.

Edit: I found that stack error happens when I load a game, it loads alright. But if I press F12 and load that is when the error occurs. Scripter friend of mine says to put "unless $@" at the end of all alias commands. So it's no scripts fault really I don't think.

I put that unless $@ at the end of the error I was getting on the ATS script and yup, works now with no error when pressing F12 and starting a new game or loading. Sounds like a good idea of what he says about how scripters should try to put that command at the end of each alias.

So yeah... thanks again for your replying and help.
« Last Edit: August 18, 2009, 01:23:30 AM by Raukue »

*
Rep:
Level 97
2014 Most Unsung Member2014 Best RPG Maker User - Engine2013 Best RPG Maker User (Scripting)2012 Most Mature Member2012 Favorite Staff Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best Use of Avatar and Signature Space2011 Best RPG Maker User (Scripting)2011 Most Mature Member2011 Favourite Staff Member2011 Best Veteran2010 Best RPG Maker User (Scripting)2010 Most Mature Member
Well, it's not a terrible idea. It's better to just use Zeriab's script, in my opinion: http://rmrk.net/index.php/topic,18900.0.html

2) looking at finished scripts give me headaches and I'm tired. This is sort of a hack fix so there might be problems. Hopefully it works though:

Spoiler for:
Code: [Select]
#==============================================================================
# ** ATS + Scene Battle ReDux Compatibility Patch
#++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
#  Instructions:
#
#    Place Scene Battle Redux under the ATS and place this script in its own
#   slot below Scene Battle ReDux. It's sort of a hack fix. I'm tired.
#==============================================================================

class Window_BattleMessageReDux < Window_BattleMessage
  #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  # * Determine Position
  #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  def determine_position
    m = $game_message
    # Set custom position if custom position desired
    # Centre by default
    x = m.message_x == -1 ? (Graphics.width - m.message_width) / 2 : m.message_x
    if m.message_y == -1
      y = $game_message.battle_interpreter ? (Graphics.height - m.message_height) : 0
      y = @position == 0 ? 0 : @position == 1 ? y / 2 : y  
    else
      y = m.message_y
    end
    width = m.message_width
    height = m.message_height
    # Adjust Window Size according to choicebox position
    if $game_message.choicebox && $game_message.choicebox_on_line && !$game_message.choice_texts.empty?
      dummy = Window_ChoiceBox.new
      commands, c_w = dummy.prepare_choices
      dummy.dispose
      width -= c_w
      x += $game_message.choicebox_width unless $game_message.faceside
    end
    # Remake the window if the new proportions do not match the old ones.
    if [x, y, width, height] != [self.x, self.y, self.width, self.height]
      remake_window (x, y, width, height)
    else
      set_position (x, y)
    end
  end
end


As for the other error - I'm not sure Possibly it's \x00 causing a problem. Try adding "\x00" to the no_args thingy; same place where it was before around line 820 (or in the Extraction Bug Fix if you have it)



instead of:

Code: [Select]
# Codes without arguments
    no_args_codes = ["\x03", "\x04", "\x05", "\x06", "\x07", "\x09",
                     "\x10", "\x95", "\x94", "\x91", "\x90", "\x89"]

change it to:

Code: [Select]
   no_args_codes = ["\x00", "\x03", "\x04", "\x05", "\x06", "\x07", "\x09",
                     "\x10", "\x95", "\x94", "\x91", "\x90", "\x89"]


P.S. I'm merging this with the real topic.

I definitely need to rewrite this script sometime soon.