Someone please help me... dire bug.

0 Members and 1 Guest are viewing this topic.

*
Rep:
Level 86
This is concerning RPG Maker 2000:

Okay I was working away on my project which has taken a couple weeks of solid work, and was shaping up very well... when all of a sudden the game glitched on me and it won't let me back into my project. I think it's because I went to make an enemy called Will o' wisp and it didn't like the apostrophe in the character name. Pretty soon after I added it to a Monster Party for use in random battles, and clicked Auto Name group, it said something like access is denied and after making another party or two (after renaming the creature to remove the apostrophe), the WHOLE FREAKING GAME I've been making won't open up. Here's the error I'm getting every time I boot up RM2K and go to open my project:

Assertion failure (D:\HOME\Lucifer\RPG_RT\GR_ChipSet.pas, 489 Row)

Also when I go into the project folder and try to run RPG_RT.exe I get an error saying "Stream Read Error"

It seems specific to someone else's computer... for a start, I don't have a secondary hard drive, my D:\ drive is a CD drive. Also, my username in windows is NOT Lucifer. Can someone please point me in the direction of a patch or give me a solve for this problem? I've got a very big, very intricate project in the works and I would HATE to lose it. Thanks in advance.

Please help me.

[EDIT]
It may also be worth noting that I ran a search on my computer for folders (not files... the error refers to a folder) called RPG_RT and came up with NOTHING.
Also, I've tried reinstalling the program and then reinstalling the patches. Nothing.

[ANOTHER EDIT]
I see why it refers to the chipset. When I right click one of my maps and click properties, I can see that the Chipsets dropdown box is empty. I can't pick one. However, when I click OK, the events show up. At the very worst I might have to copy and paste the events into a new project... if that's what I'm forced to do can someone explain where the creature / skills / item information is stored? Hopefully I can salvage that so it doesn't force conflicts when looking for stuff in my events that aren't in the database.
« Last Edit: March 10, 2008, 01:29:26 PM by PsychoticSquid »

**
Rep:
Level 88
Where's the head of a chocolate coronet? :O
That would be the worse case scenario. However, you can easily make everything up. All you need to do is just get all of the resources moved onto a new project, copy and paste the Database works (Which I assume can be either time consuming or quick, RPG XP makes it very simple, but this 2k), and then copy all the maps over. That's my thinking however for the pessimistic solution.

However, it is not an apostrophe that made this catastrophe (Rhyme intended). I have a monster that is named "Lil' Warrior". He works A-OK when fighting in the Test Battle. Real game pending, but it probably is the same results. And I just had Will O' Wisp on the Monsters, to test if it works. And whoop-de-doo, it did work.

The problem with the RPG RT, which I can only assume is that it's because it's on a CD Drive, but that is a very lame conclusion, for stuff can still work on CD Drives, it just won't save files...(Though strangely I actually got some file to save on a non-burnable Hard Drive thingie o.o).

On the search, search RPG_RT.exe rather than RPG_RT. Or RPG. Or RT. Who knows.

Good luck, and sorry for not being able to find a solution. At least the apostrophe isn't the problem...hopefully.

*
Rep:
Level 86
Thanks for the reply, Starrodkirby86.

I did some googling about this problem and it looks to be very common. Unfortunately I didn't find anything particularly useful online in regards to a solution but I did a bit of fishing around myself and figured out something that might be of use to others. This might be able to help anyone in future that has the same problem... but I'll say now that it still involves some work (a lot of work if your game is significantly developed).

What's happened is that for some reason, when the program glitches like that it wipes the file RPG_RT.lmt (or it might have been the RPG_RT.ldb one). You can look at the file properties in windows after you get the error and see that it has a filesize of 0 bytes, just to make sure which one. The file in question seems to be where the stuff in your database is stored. While there is no way to retrieve the lost information, you can do what I did and get most of your game back.

You need to copy the corresponding file from the sample game that comes packaged with RM2K (or alternatively, if you have deleted the sample game, create a new, blank project and save it so you can use that instead) and place it in your game's directory.

Here's the heartbreaker: Your database is returned to default. That means all your items, attacks, battle animations, monsters, party information, names of switches, etc. are set to those of the sample game. This causes some association problems that unfortunately you'll have to use your memory and a lot of research to resolve. For example, let's say you had item number 1 set up as a sword. In your game any event that gives you the sword will instead give you the default item it's been returned to. You need to go through all your events, shops, etc. and write a list of what has been changed to what, and manually create them all again in the exact same spot. Same goes for monsters and monster parties, so you'll need to check all your areas again and work out which enemies you had in what slots. Make sure you use a fine tooth comb and go through every single thing, or you're gonna have some strange stuff happen in the future.

The GOOD side of this solution is (apart from actually being able to open your game) that your events still all work correctly, even those that use switches. All that's changed where switches are concerned are their labels, which unfortunately will be a little confusing if you use some of them commonly and need to select it for new events. Once again, you need to look back through all the significant events again if you want to determine which switch was which (we're both poets), and rename them to something you'll remember. The best thing though is even if you don't do this, you can play your game and you'll notice that all the switches work correctly. The functions of your switches are stored with the events they are used in, seperately from their labels, so luckily you don't have sample game events happening randomly. What you do need to do, however, is remove the sample game common events and put your own back in there (if any).

It's sad to lose so much but this way, at least you don't have to start from scratch. You still have your maps, and you still have your events (except for your commons)... and if you're like me, you use a lot of events. Losing my events would have basically meant I'd be better off making a new game anyway. This way I didn't have to!

Wish I could have came up with a cleaner solution but for now this is all I can find. I'm trying to work out what causes it... but you are correct that it is not the apostrophe. In fact the sample game has an enemy called Will'o'wisp already. For now, just make sure every time you finish something significant that you copy your game's directory and paste it into another folder somewhere as backup. Hope this helps anyone else with this problem!