[XP] The problem with Vista. Check here if you have Vista, before posting.

0 Members and 2 Guests are viewing this topic.

*
Rep: +0/-0Level 83
Thats just it i get he the rpg maker has failed error as well and i dont have the ini file. instead of an ini file i have this rggs player file which  is named the same thing a previous post called the ini file. ( im not offended or being condescending just letting you know) and I know what an ini file looks like i tweak mine on oblivion about once a week. Its just that i cant find the ini file at all. sry for taking so long to reply i ahd given up hope on getting any reply

*
Rep: +0/-0Level 82
I got rpg maker 2k3 to create a new project on vista after it wasnt working.

First i put it into compatability and administration mode like deliciously previously explained.

Then i opened rpg 2k3 and clicked the "create a new project" button and changed the project path to the "Project" folder in rpg maker 2k3 in the program files. For mine it says C:\Program Files (x86)\rpg maker\rpg2k3\Project since i changed the location while installing rpg 2k3 in the first place. (except with weird Y symbols instead of "\" symbols)

After that i just made sure the Project had all the RTP in the right place since everything was blank (im not sure if your suppose to manually copy and paste it into your project folder from the main folder but thats what i did) and so far it works normally.

This might be a one person situation that i fixed and might not work for you but i hope it does.

Hope this helps for those who got trapped with the pre-installed gimped vista and whatnot. gl.

***
Rep:
Level 87
Musician & Artist
I just figured out how to fix Vista Issues everyone was having trouble with. I've not seen a solution for this anywhere. Heres how to fix Rpgmaker XP "RGSS as stoped working" with windows vista.

Make sure the dll files are in c:windows\system32
Goto Control Panel > System >Advance system settings "Under Performace" Click Settings
Goto -Data Excutution Prevention- Click add, and add the game.exe of your game.

Click apply...

All fixed :)
« Last Edit: January 02, 2010, 05:34:57 PM by Treign »
Dorman. T Reign

*
Rep: +0/-0Level 81
Hey guys, i have windows 7 64 bit and running rpgmaker xp.

I thought i would share with you guys the way to fix it !! I could not find a solution on the net. This is to address the problem that no matter what you do, you get the error cannot open in less then 1024x768 message.


Some people say disable arro or to run in compatibility mode, none really works!!

But what you have to do is this, and it will work. At least it did for me.

goto your programfiles/enterbrain/ or whever you installed it

mine was in C:\Program Files (x86)\Enterbrain

edit the rpgxp application by right clicking it

hit properties and goto compatibility

and checkmark the box that says Disable display scaling on high DPI systems

do the same with the game.exe in the system folder.

I did this, and it works! I thought i would create an account and respond to this thread and give other people hope that you can get it running, up until now, i was running rpgmaker on a windows xp virtual machine i setup! Thank god I do not have to go through that again!

This works but! Everything is rather smallish on the editer and tile map editing screen, i will try and fix it and let you all know what i did. Although it could be my current resolution is 1920x1200 I think if i were to lower it, rpgmaker would open allot cleaner, but that is misc. configeration issues!!

I hope this helps! Also check out my rpgmaker game kingdom of auspiex

http://koarpg.com and our forum http://koarpg.com/forum/

cya

*
Rep:
Level 97
2014 Best RPG Maker User - Engine2014 Most Unsung Member2013 Best RPG Maker User (Scripting)2012 Favorite Staff Member2012 Most Mature Member2012 Best RPG Maker User (Scripting)2012 Best MemberSecret Santa 2012 ParticipantProject of the Month winner for July 20092011 Best RPG Maker User (Scripting)2011 Best Veteran2011 Favourite Staff Member2011 Most Mature Member2011 Best Use of Avatar and Signature Space2010 Favourite Staff Member2010 Most Mature Member
Thanks for sharing that solution, koa

*
Rep: +0/-0Level 81
NO worries my pleasure, I have been working on a rpgmaker game for 4 years now, its getting near to done, one of the few early day netplay games, that transitioned to an entirely new server and code base, I will post a demo soon for you guys to enjoy, as I need to recruit some artists and will pay! I hope this tutorial I posted above helps people who have the 1024x768 bug even though they are running rpgmaker above those settings for their resolution.

**
Rep: +0/-0Level 75
RMRK Junior
i tried to run rmxp in compatibility mode but when i double click the "RPGXP.exe" it won't open. There are no error messages poping-out. i already tried all the solutions posted here but still it doesn't work.

*
Rep: +0/-0Level 83
Escape to the Stars
I FIXED IT!!!!!!!! :bean:

Here's the problem:
For whatever stupid reason, rgss100j.dll doesn't work properly in Vista, so what you have to do is open the "game.ini" config settings in your game's folder using notepad, and where it says

Library=RGSS100J.DLL, change it to Library=RGSS102E.DLL

The game and player WORK FINE!

oh, and obviously that must mean you have to have rgss102e.dll

Edit: Turns out ya still need the Official Version to use the music player, not sure why though...
This did it for me. Thanks! I had the .dll file I just forgot to edit the .ini file.

Finally I can create RPGs again.

Edit 1: Or not. One of my older ones started working, but the others still don't. I'll get back to you on this.

Edit 2: Got it! Add what Treign said and it works perfectly.
« Last Edit: December 02, 2010, 05:11:10 AM by animefangel »

Before, I stargazed and read books by myself... I thought that's all I would ever want... But now... I feel lonely without you next to me.
Projects: (Working Titles)
The Demon Tree
Night Breed
Grimm's Law
(I could use all the help I can get.)
Thanks to my twin and my brother for their help with character design and music.