[XP] The problem with Vista. Check here if you have Vista, before posting.

0 Members and 1 Guest are viewing this topic.

**
Rep: +0/-0Level 86
There is no spoon...
Vista Ultimate user here and RPG Maker XP runs 100% fine.

To all you newbies out there, if you don't meet the minimum requirements for the os, DON'T GET THE DAM THING.

*
? ? ? ? ? ? ? ? ? The nice kind of alien~
Rep:
Level 91
Martian - Occasionally kind
Vista Ultimate user here and RPG Maker XP runs 100% fine.

To all you newbies out there, if you don't meet the minimum requirements for the os, DON'T GET THE DAM THING.

Do you have a 32-bit version or a 64-bit version?
I have a suspicion that RMXP does not run on 64-bit. I am unfortunately unable to test this.

******
Rep:
Level 88
Let's attack agressively.
DAMM YOU VISTA!

when i run RPG maker XP, it will give me this error: "Critical Error C0000005 at address 00000000"

VISTA IS A PILE OF JUNK!

Quote
The most important tip: UNINSTALL VISTA YOU MORON.

How? My laptop came with Window Vista Basic......... ;9     :mad:(S%$^)

***
Rep:
Level 86
downloaded the paying one nd it says failed to obtain serieal number from the nTitle server
never mind fixd it run as adminerstartor,,,,,thank God i finaly fixd it,,,now i can become one of thr rpgmaker xp users
« Last Edit: June 22, 2007, 11:43:30 PM by ChaosSoldier92 »

******
Rep:
Level 88
Let's attack agressively.
ok...... ;9

tell me if im correct, i go to the RPG maker XP file where i saved it, i right-click the exe file and run it as administrator? or do i have to go somewhere esle to do it?

EDIT: Nope.......nothing, still have the error "Critical Error C0000005 at adress 00000000"........;9;9
I really want ot use XP so i can make a game there too........Vista is Crap (srry for language)
« Last Edit: June 23, 2007, 05:14:29 AM by AlienSoldier »

***
Rep:
Level 86
u hav e to go where the program is saved ...then right click as adminersrater


ok...... ;9

tell me if im correct, i go to the RPG maker XP file where i saved it, i right-click the exe file and run it as administrator? or do i have to go somewhere esle to do it?

EDIT: Nope.......nothing, still have the error "Critical Error C0000005 at adress 00000000"........;9;9
I really want ot use XP so i can make a game there too........Vista is Crap (srry for language)

*
? ? ? ? ? ? ? ? ? The nice kind of alien~
Rep:
Level 91
Martian - Occasionally kind
There are many different versions of Windows Vista.

Which version are you using Chaos?

******
Rep:
Level 88
Let's attack agressively.
-----ChaosSoldier92
I did run it as administrator but when i do something like play a music there, it will give me the error....


i dunno what version i have......it said Window Vista Basic....where do i check it?

***
Rep:
Level 86

idk i didnt start my music stuff yet im juzt developing my story and nd gettin some graphics


-----ChaosSoldier92
I did run it as administrator but when i do something like play a music there, it will give me the error....


i dunno what version i have......it said Window Vista Basic....where do i check it?

***
Rep:
Level 87
I FIXED IT!!!!!!!! :bean:

Here's the problem:
For whatever stupid reason, rgss100j.dll doesn't work properly in Vista, so what you have to do is open the "game.ini" config settings in your game's folder using notepad, and where it says

Library=RGSS100J.DLL, change it to Library=RGSS102E.DLL

The game and player WORK FINE!

oh, and obviously that must mean you have to have rgss102e.dll

Edit: Turns out ya still need the Official Version to use the music player, not sure why though...
« Last Edit: July 31, 2007, 12:10:44 PM by da good king »

***
Rep:
Level 88
downloaded the paying one nd it says failed to obtain serieal number from the nTitle server
never mind fixd it run as adminerstartor,,,,,thank God i finaly fixd it,,,now i can become one of thr rpgmaker xp users
I had this same problem on Vista Ultimate 64bit ,how did u fixed this? Please e-mail me at patmi@mj-soft.net
THANX

*
Rep:
Level 86
I just got a laptop with Vista Home Basic (yeah, it was bundled....) - installed RMXP and got the "Cannot connect to ntitles server" error.  Right-click RMXP.exe and set to run as administrator and it seems to have fixed the problem - for now.  Haven't had any of the other error messages yet.

Thanks for posting this list of fixes!
Always remember you're unique.
Just like everybody else.

*
Rep:
Level 102
2014 Best Non-RM Creator2014 Biggest Forum Potato2014 Biggest Narcissist Award2013 Best IRC Chatterbox2013 Best Game Creator (Non-RM)Participant - GIAW 112012 Best Use Of Avatar and Signature space2012 Funniest Member2012 Most Successful Troll2012 Best IRC ChatterboxSecret Santa 2012 ParticipantProject of the Month winner for November 2009For being a noted contributor to the RMRK Wiki2010 Best IRC Chatterbox2010 Biggest Forum Couch Potato2010 Most Successful Troll
Well umm....RPG Maker XP works for me in VIsta...I didn't really do anything either.

***
Rep:
Level 87
well yeah, your using the official verison which works fine, it's the Enterbrain version which has all the damn problems. Kind of why I decided it was finally time to buy the damn thing.

*
Rep:
Level 102
2014 Best Non-RM Creator2014 Biggest Forum Potato2014 Biggest Narcissist Award2013 Best IRC Chatterbox2013 Best Game Creator (Non-RM)Participant - GIAW 112012 Best Use Of Avatar and Signature space2012 Funniest Member2012 Most Successful Troll2012 Best IRC ChatterboxSecret Santa 2012 ParticipantProject of the Month winner for November 2009For being a noted contributor to the RMRK Wiki2010 Best IRC Chatterbox2010 Biggest Forum Couch Potato2010 Most Successful Troll
Enterbrain IS the legal version.

***
Rep:
Level 87
whatever, im slow. The free version sucks, end of story.

*
Rep:
Level 86
For whatever stupid reason, rgss100j.dll doesn't work properly in Vista, so what you have to do is open the "game.ini" config settings in your game's folder using notepad, and where it says

Library=RGSS100J.DLL, change it to Library=RGSS102E.DLL

The game and player WORK FINE!

you are a TOTAL LEGEND!
Vista Home Basic, 32 bit.  RMXP has been running fine (official version) when run as administrator but I needed to do the above to get rid of my "RGSS Player Stopped Working" message.  SO glad you posted this solution!
Always remember you're unique.
Just like everybody else.

*
Rep:
Level 102
2014 Best Non-RM Creator2014 Biggest Forum Potato2014 Biggest Narcissist Award2013 Best IRC Chatterbox2013 Best Game Creator (Non-RM)Participant - GIAW 112012 Best Use Of Avatar and Signature space2012 Funniest Member2012 Most Successful Troll2012 Best IRC ChatterboxSecret Santa 2012 ParticipantProject of the Month winner for November 2009For being a noted contributor to the RMRK Wiki2010 Best IRC Chatterbox2010 Biggest Forum Couch Potato2010 Most Successful Troll
For whatever stupid reason, rgss100j.dll doesn't work properly in Vista, so what you have to do is open the "game.ini" config settings in your game's folder using notepad, and where it says

Library=RGSS100J.DLL, change it to Library=RGSS102E.DLL

The game and player WORK FINE!

you are a TOTAL LEGEND!
Vista Home Basic, 32 bit.  RMXP has been running fine (official version) when run as administrator but I needed to do the above to get rid of my "RGSS Player Stopped Working" message.  SO glad you posted this solution!
Legend? lol

*
Rep:
Level 86
lol - leave me alone! :D
Always remember you're unique.
Just like everybody else.

***
Rep:
Level 87
Good thing I don't have Vista  :P

Actually, neither do I. It would be a big help if someone who did, would test some things for me...
if you still need someone to test some things with Vista i could, i have the same problems as every1 else, but i still have all my files on my other comp which is XP so my stuff is safe and i can mess around with RMXP in Vista.



I FIXED IT!!!!!!!! :bean:

Here's the problem:
For whatever stupid reason, rgss100j.dll doesn't work properly in Vista, so what you have to do is open the "game.ini" config settings in your game's folder using notepad, and where it says

Library=RGSS100J.DLL, change it to Library=RGSS102E.DLL

The game and player WORK FINE!

oh, and obviously that must mean you have to have rgss102e.dll

Edit: Turns out ya still need the Official Version to use the music player, not sure why though...
what exactly does this fix? i tried it and i still get the same problem.




edit: BTW My RPG Maker XP runs and i can do stuff with it, but as soon as i playtest i get "RGSS player has stopped working" and it doesn't playtest, but i figured out that it does this when you save, i literally opened up a project, playtested it, it worked, then saved and playtested again and it gave me the error message again, just thought it would help in looking fo a solution....
« Last Edit: December 10, 2007, 10:58:33 AM by atracious »
"Facts are useless. You could use facts to prove anything that's even remotely true." Homer Jay Simpson

"I do not know what weapons WWIII will be fought with but i know WWIV will be fought with sticks and stones" Albert Einstein

"It's better to have loved and lost than never to have loved at all." from In Memoriam, by Alfred, Lord Tennyson.

"all your base are belonging to us!" awful fantasy 3

"the grapes damb it, it's alway's the grapes!"

Funny anagrams:
Desperation=A rope ends it
Mother in law=Woman hitler
Lottery machine=Money lost in 'em
Election results=Lies lets recount
Dormitory=Dirty room
Snooze alarms=Alas! No more Z's
Eleven plus two=Twelve plus one
Cosmetic surgery="Yes, I correct mugs."
The IRS=Theirs!
Public relations=Crap, built on lies
Astronomer=Moon starer
Dementia="Detain me."
Internet chat rooms=The moron interacts
The eyes!=They see!

Currently making:
http://rmrk.net/index.php/topic,13132.0.html

***
Rep:
Level 87
the reason is that for some EXTREMELY ANNOYING reason projects saved using the free version automatically re-assingn the library to rgss100j.dll so you have to keep editing that stupid .ini file EVERY SINGLE TIME YOU SAVE AND CLOSE THE PROGRAM!!!

rly sry bout that yall i havent found a solution to get it to NOT re-assign it but ill post bak if i do

***
Rep:
Level 87
the reason is that for some EXTREMELY ANNOYING reason projects saved using the free version automatically re-assingn the library to rgss100j.dll so you have to keep editing that stupid .ini file EVERY SINGLE TIME YOU SAVE AND CLOSE THE PROGRAM!!!

rly sry bout that yall i havent found a solution to get it to NOT re-assign it but ill post bak if i do
Oh, now it works! yay, thanks so much! But it is kinda anoying to have to change it every time.  :(  hope you can fix that soon  too :D
"Facts are useless. You could use facts to prove anything that's even remotely true." Homer Jay Simpson

"I do not know what weapons WWIII will be fought with but i know WWIV will be fought with sticks and stones" Albert Einstein

"It's better to have loved and lost than never to have loved at all." from In Memoriam, by Alfred, Lord Tennyson.

"all your base are belonging to us!" awful fantasy 3

"the grapes damb it, it's alway's the grapes!"

Funny anagrams:
Desperation=A rope ends it
Mother in law=Woman hitler
Lottery machine=Money lost in 'em
Election results=Lies lets recount
Dormitory=Dirty room
Snooze alarms=Alas! No more Z's
Eleven plus two=Twelve plus one
Cosmetic surgery="Yes, I correct mugs."
The IRS=Theirs!
Public relations=Crap, built on lies
Astronomer=Moon starer
Dementia="Detain me."
Internet chat rooms=The moron interacts
The eyes!=They see!

Currently making:
http://rmrk.net/index.php/topic,13132.0.html

**
Rep: +0/-0Level 85
After 4 hours of installing, uninstalling every version of RMXP, I have given up and will try VX when it comes out.

****
When the dawn breaks...
Rep:
Level 88
...tonight will be just another memory.
You shouldn't have a problem with RMXP on vista anymore if you do the above.

***
Rep:
Level 87
the reason is that for some EXTREMELY ANNOYING reason projects saved using the free version automatically re-assingn the library to rgss100j.dll so you have to keep editing that stupid .ini file EVERY SINGLE TIME YOU SAVE AND CLOSE THE PROGRAM!!!

rly sry bout that yall i havent found a solution to get it to NOT re-assign it but ill post bak if i do
Oh, now it works! yay, thanks so much! But it is kinda anoying to have to change it every time.  :(  hope you can fix that soon  too :D

OK this will make all of this easier!
When you change the config file from 100j to 102e also make the file read only:
1. right click on the config file.
2. go to properties.
3. at the bottom check the read-only box.
4. click Apply.
When you open the project it removes the read-only but, if you put it back to read-only AFTER you open it, it has no problems with saving, so you can mess around all you want till you close it, then when you open the project again, just set the read-only status before you do any saving and you will be fine, IF this doesn't work for you let me know, but that's a big if.....
« Last Edit: December 29, 2007, 12:20:53 AM by atracious »
"Facts are useless. You could use facts to prove anything that's even remotely true." Homer Jay Simpson

"I do not know what weapons WWIII will be fought with but i know WWIV will be fought with sticks and stones" Albert Einstein

"It's better to have loved and lost than never to have loved at all." from In Memoriam, by Alfred, Lord Tennyson.

"all your base are belonging to us!" awful fantasy 3

"the grapes damb it, it's alway's the grapes!"

Funny anagrams:
Desperation=A rope ends it
Mother in law=Woman hitler
Lottery machine=Money lost in 'em
Election results=Lies lets recount
Dormitory=Dirty room
Snooze alarms=Alas! No more Z's
Eleven plus two=Twelve plus one
Cosmetic surgery="Yes, I correct mugs."
The IRS=Theirs!
Public relations=Crap, built on lies
Astronomer=Moon starer
Dementia="Detain me."
Internet chat rooms=The moron interacts
The eyes!=They see!

Currently making:
http://rmrk.net/index.php/topic,13132.0.html